android错误之Unable to resolve target ‘Google Inc.:Google APIs:6’

在导入一个项目是,出现

Unable to resolve target ‘Google Inc.:Google APIs:6’

 

按下面方式解决:

 

修改目录下的project.property文件内容为

target=Google Inc.:Google APIs:16(在这里他本来可能是其他版本号,不用管它,只需要改成你所导入的包的版本就行,

比如我这里已经导入就是api16而他的本来版本是6)

 

如果不知道自己导入的是什么版本,还是出错,那么尝试如下操作:

1,重新导入包

到android的sdk下的add-on里找到map.jar,

比如我的路径为E:\Android\android-sdk\add-ons\addon-google_apis-google-15\libs\map.jar。

确保正确导入进去

2.重复上面说的修改版本号的做法既可.

标签