android中版本webView中js不执行问题

关于android中版本大于等于17后webView中js不执行问题。

android中webView中Js不执行是因为版本的问题,大于等于17后就需要对调用方法加注解才会执行。

解决方法如下:

其实很简单,就是在你的js调用的方法上面加@JavascriptInterface就OK啦!

比如:js代码如下:

[html]

  1. <SCRIPT language=JavaScript>  
  2.  function getNext(url,d){  
  3.       javascript:myjavascript.getNext(url,d,1);  
  4.   }  
  5. </SCRIPT>   



js调用的方法如下:

[html]

  1.  public void getNext(String url,String direction,int dialog){  
  2.    。。。。。。  
  3. }  


在getNext方法上面加注解,导入相应的包后就ok,如下:

[html]

  1. @JavascriptInterface  
  2.  public void getNext(String url,String direction,int dialog){  
  3.    。。。。。。  
  4. }  



17以上的和一下的android版本都会执行webView中的Js。

标签